CityVilleBot (Project DEVIL)
Search
 
 

Display results as :
 


Rechercher Advanced Search

Latest topics
» Try LilyCity HD, it's a real cityville clone
Mon Apr 20, 2015 1:52 pm by ertyanna

» expansions cityville hack new 12/12/15
Sat Feb 14, 2015 9:52 pm by nico

» Biohazard Problem Expansion
Sat Nov 08, 2014 3:12 pm by CV FO LIFE

» CAN SOMEONE HELP ME?
Sat Nov 08, 2014 3:09 pm by CV FO LIFE

» hello friends i have new update of cv bot project devil 1.10 update (2.01)
Sat Nov 01, 2014 12:59 pm by Blue Angel

» [Resolved] codebase-php Error
Sun Oct 12, 2014 7:22 am by nico

» -_- Which bot is now working ????
Thu Oct 09, 2014 7:06 pm by lobobpf6

» bot 1.2 does nt work
Sun Aug 10, 2014 1:00 am by nathaliafariass

» COMO FUNCIONA
Sun Aug 10, 2014 12:38 am by nathaliafariass

Affiliates
free forum


Project DEVIL 1.10 (29.10.2011)

Page 3 of 12 Previous  1, 2, 3, 4 ... 10, 11, 12  Next

View previous topic View next topic Go down

Re: Project DEVIL 1.10 (29.10.2011)

Post  kns4945 on Fri Sep 23, 2011 12:40 pm

Good job .............But old bot is better this Bot dont load game farms it shows errors

i have to open both ie and this bot to make this bot work make a better version
avatar
kns4945

Posts : 9
Points : 17
Join date : 2011-09-23
Age : 70
Location : india

http://www.facebook.com/greek123

Back to top Go down

Re: Project DEVIL 1.10 (29.10.2011)

Post  Admin on Fri Sep 23, 2011 1:25 pm

kns4945 wrote:Good job .............But old bot is better this Bot dont load game farms it shows errors

i have to open both ie and this bot to make this bot work make a better version

you dont demand anything in this forum.. you can SUGGEST or HELP with the problems...

Just READING a lil bit you can notice its a working in progress... and that defines everthing...

You are not happy with it?! its not my problem.. keep using the old bot then...

* besides today Z* introduced the last part of the quest for the Eiffel Tower (wonder).. the servers are already overloaded and quite slow today *

Admin
Admin

Posts : 80
Points : 50
Join date : 2011-09-21

http://cityvillebot.forumotion.eu

Back to top Go down

Re: Project DEVIL 1.10 (29.10.2011)

Post  cediel on Fri Sep 23, 2011 2:22 pm

how do I run the cityreq me so I sent out the items

cediel

Posts : 1
Points : 1
Join date : 2011-09-23

Back to top Go down

Re: Project DEVIL 1.10 (29.10.2011)

Post  kns4945 on Fri Sep 23, 2011 2:26 pm

ha thanks for reply i uses old bot which i edited and finally i made it work but i dont know how to make hotel plugin v1.4 work
avatar
kns4945

Posts : 9
Points : 17
Join date : 2011-09-23
Age : 70
Location : india

http://www.facebook.com/greek123

Back to top Go down

cruise ship

Post  Chr0niC on Fri Sep 23, 2011 2:54 pm

looks like the code for cruiseship has been changed by Z*nga
Code:
 
[16:48:23] > Loading configuration.
[16:48:23] ERROR: Invalid commodity.
[16:48:22] -> Supply ship_cruise x=-46 y=29
[16:48:22] [BUILDINGS-Cruise] Supplying Cruise Ship
[16:48:22] [BUILDINGS-Cruise] Action started..

Chr0niC

Posts : 14
Points : 16
Join date : 2011-09-21

Back to top Go down

Re: Project DEVIL 1.10 (29.10.2011)

Post  tcguy on Fri Sep 23, 2011 3:13 pm

Hi.mine dont start.on the bottom say waiting AMF data.what that means?please help me.thanks

tcguy

Posts : 1
Points : 1
Join date : 2011-09-23

Back to top Go down

Re: Project DEVIL 1.10 (29.10.2011)

Post  Admin on Fri Sep 23, 2011 4:50 pm

IMPORTANT NOTE (23.09.2011)
Today i have been experiencing some big problems on trying to play CityVille (using the BOT or a normal Browser)...

Z* released today the last part of the quest for Eiffel Tower (Wonder)... the servers are inflamed somehow.. maybe is the new contents...
Also the new flash version was released today 10,3,183,10 after updated to this version i noticed "laziness" progress whatever program im using.. (BOT or IE)...
When i managed to finally connect i had some problems on the "Loading configuration..." and got stuck quite a few times..
i cant tell for sure whats going on.. becos it sudenly started to act like this...
Maybe the new content on Z* servers with the overload of users.. maybe the new flash version... or mayb something else..

but after some time i managed to run the bot quite smooth like before.. i guess it is just metter of time to the servers back to the "normal"..


in middle time you can try do something on the BotClass.php inside your codebase-php directory...
find the function ReloadConfig() and change...
this:
Code:
$amf->_bodys[0]->responseURI = '/1';
replacing with this:
Code:
$amf->_bodys[0]->responseURI = '';

and see if works for you...
thx

Admin
Admin

Posts : 80
Points : 50
Join date : 2011-09-21

http://cityvillebot.forumotion.eu

Back to top Go down

Re: Project DEVIL 1.10 (29.10.2011)

Post  <BQ> on Fri Sep 23, 2011 5:51 pm

Admin wrote:
in middle time you can try do something on the BotClass.php inside your codebase-php directory...
find the function ReloadConfig() and change...
this:
Code:
$amf->_bodys[0]->responseURI = '/1';
replacing with this:
Code:
$amf->_bodys[0]->responseURI = '';

and see if works for you...
thx

fix this changing the reload funktion?

<BQ>

Posts : 221
Points : 226
Join date : 2011-09-21

Back to top Go down

Re: Project DEVIL 1.10 (29.10.2011)

Post  Admin on Fri Sep 23, 2011 6:01 pm

<BQ> wrote:
fix this changing the reload funktion?

its not a fix.. it just for trying purposes...



I guess some major maintenance is happening on the FB or Z* servers...

The address: fb-client-1.cityville.zynga.com is just dynamic.. it points you to a holy bunch of IPs wich are the real server files...
and some of them are having some problems atm...
you can try your self do a PING command using the cmd.exe: ping fb-client-1.cityville.zynga.com you will notice diferent IPs..
and some of them im getting "Request timed out.".. thats why im geting stuck on "Load configurations...." part..
at some point im getting those IPs that are not working very well atm

Admin
Admin

Posts : 80
Points : 50
Join date : 2011-09-21

http://cityvillebot.forumotion.eu

Back to top Go down

Thought you might wanna know. I got this error.

Post  bisaro on Fri Sep 23, 2011 6:21 pm

BOT IS STOPED.
PHP Warning: shuffle() expects parameter 1 to be array, null given in D:\Games\CVBot - Project DEVIL 1.01\Plugins\Neighbors\Hooks.php on line 655
PHP Warning: shuffle() expects parameter 1 to be array, null given in D:\Games\CVBot - Project DEVIL 1.01\Plugins\Neighbors\Hooks.php on line 655

Got the above error. BTW STOPED shd be STOPPED. Very Happy

bisaro

Posts : 1
Points : 1
Join date : 2011-09-23

Back to top Go down

Re: Project DEVIL 1.10 (29.10.2011)

Post  dada79 on Fri Sep 23, 2011 7:07 pm

Code:
BOT IS STOPED.
If running on windows 7, please run the bot as administrator
Cannot find MainRequest.bin or Headers.bin
è Bot Init [Phase 1]

--------------------------------------------------------------------------------
BOT IS RUNNING.
BOT IS STOPED.
If running on windows 7, please run the bot as administrator
Cannot find MainRequest.bin or Headers.bin
è Bot Init [Phase 1]

--------------------------------------------------------------------------------
BOT IS RUNNING.
BOT IS STOPED.
ERROR: User not foundThe session expired, the bot will restart in 5 seconds
WAITING AMF DATA.
ERROR: User not foundThe session expired, the bot will restart in 5 seconds
Loading configuration...
UpdateXML
è Bot Init [Phase 1]

dada79

Posts : 53
Points : 38
Join date : 2011-09-21

Back to top Go down

Re: Project DEVIL 1.10 (29.10.2011)

Post  dada79 on Fri Sep 23, 2011 7:15 pm

Admin wrote:
its not a fix.. it just for trying purposes...



I guess some major maintenance is happening on the FB or Z* servers...

The address: fb-client-1.cityville.zynga.com is just dynamic.. it points you to a holy bunch of IPs wich are the real server files...
and some of them are having some problems atm...
you can try your self do a PING command using the cmd.exe: ping fb-client-1.cityville.zynga.com you will notice diferent IPs..
and some of them im getting "Request timed out.".. thats why im geting stuck on "Load configurations...." part..
at some point im getting those IPs that are not working very well atm

But with old bot revamped this issue doesn't appears ...

dada79

Posts : 53
Points : 38
Join date : 2011-09-21

Back to top Go down

Access Violation

Post  jrwinl on Fri Sep 23, 2011 7:33 pm

Hey guys, has anybody encountered this error?



I'm running Windows 7, updated flash, run the bot as admin.
When I open the bot, this error comes out after a minute or so and nothing else happens after that.
I tried to close it and run again but the same thing happens.


Last edited by jrwinl on Fri Sep 23, 2011 7:40 pm; edited 1 time in total

jrwinl

Posts : 2
Points : 3
Join date : 2011-09-23

Back to top Go down

Re: Project DEVIL 1.10 (29.10.2011)

Post  <BQ> on Fri Sep 23, 2011 7:34 pm

dada79 wrote:
Admin wrote:
its not a fix.. it just for trying purposes...



I guess some major maintenance is happening on the FB or Z* servers...

The address: fb-client-1.cityville.zynga.com is just dynamic.. it points you to a holy bunch of IPs wich are the real server files...
and some of them are having some problems atm...
you can try your self do a PING command using the cmd.exe: ping fb-client-1.cityville.zynga.com you will notice diferent IPs..
and some of them im getting "Request timed out.".. thats why im geting stuck on "Load configurations...." part..
at some point im getting those IPs that are not working very well atm

But with old bot revamped this issue doesn't appears ...

with the revamped bot, I read too over the problem that by peoples the bot stuck on "Load configurations...."

<BQ>

Posts : 221
Points : 226
Join date : 2011-09-21

Back to top Go down

Re: Project DEVIL 1.10 (29.10.2011)

Post  dada79 on Sat Sep 24, 2011 12:09 am

I ve fixed an issue for process visit tikisocialbusiness and casinosocialbusiness buillding in BotClass.php , function processVisits & processVisitsFragment , className:SocialBusiness is add to code :

Code:
// ============================================================================== by pjhkaka
   function processVisits($obj, $silent = true) {
      $extraVisits = $obj['lastSavedMax'] - $obj['visits'];
      if ($obj["className"] == "Hotel" ||
        $obj["className"] == "Mall" ||
      $obj["className"] == "SocialBusiness" ||
        (isset($obj["derivesFrom"]) && ($obj["derivesFrom"]=="hotel_sailboat_low")))
        {
        $extraVisits = $obj['mechanicData']['harvestState']['customersReq'] - $obj['mechanicData']['harvestState']['customers'];
        }

      if($silent)$this->SendMsg('-> Visiting: [' . $obj['itemName'] . "] $extraVisits times. ");
      unset($this->error_msg);

      for ( $i = $extraVisits ; $i > 0 ; $i = $i - 100){
         if ( $i > 100 ) $this->processVisitsFragment($obj, 100, $silent);
         else $this->processVisitsFragment($obj, $i, $silent);
      }
   }
// ============================================================================== by pjhkaka
   function processVisitsFragment($obj, $extraVisits, $silent = true) {
      // if($silent) $this->SendMsg("$extraVisits times ");
      unset($this->error_msg);

      $objid = (string) $obj['id'];
      $amf = new AMFObject("");
      $amf->_bodys[0] = new MessageBody();
      $amf->_bodys[0]->_value[0] = $this->GetAmfHeader();

      $amf->_bodys[0]->targetURI = 'BaseService.dispatchBatch';
      $amf->_bodys[0]->responseURI = '';
      $amf->_bodys[0]->_value[2] = 0;

      $amf->_bodys[0]->_value[1][0]['sequence'] = $this->GetSequense();;
      $amf->_bodys[0]->_value[1][0]['functionName'] = "UserService.processVisitsBatch";

      $amf->_bodys[0]->_value[1][0]['params'][0][$objid]['NPCEnterAction']['npcBreakDown']['residence'] = $extraVisits;

      if( $obj['className'] == "Hotel" || $obj['className'] == "Mall" || $obj["className"] == "SocialBusiness") $type = "harvestState";
      else $type = "visits";
      $amf->_bodys[0]->_value[1][0]['params'][0][$objid]['NPCEnterAction']['type'] = $type;
      $amf->_bodys[0]->_value[1][0]['params'][0][$objid]['NPCEnterAction']['count'] = $extraVisits; // the max amount of visitors.
      $amf->_bodys[0]->_value[1][0]['params'][0][$objid]['NPCEnterAction']['operation'] = "process";

      $serializer = new AMFSerializer();
      $result = $serializer->serialize($amf);
      $x = $this->SendRequest($result);
      $this->Add2Report('processVisits');
   }
// ==============================================================================

dada79

Posts : 53
Points : 38
Join date : 2011-09-21

Back to top Go down

Re: Project DEVIL 1.10 (29.10.2011)

Post  <BQ> on Sat Sep 24, 2011 1:25 am

dada79 wrote:I ve fixed an issue for process visit tikisocialbusiness and casinosocialbusiness buillding in BotClass.php , function processVisits & processVisitsFragment , className:SocialBusiness is add to code :

hehe, two mans with the same thoughts

<BQ>

Posts : 221
Points : 226
Join date : 2011-09-21

Back to top Go down

Re: Project DEVIL 1.10 (29.10.2011)

Post  dada79 on Sat Sep 24, 2011 1:33 am

Code:
[03:27:01] ERROR: Wonder::getRadius - Invalid client enqueue time
[03:27:00] -> Harvesting: casino_social_business (id:5363)
[03:27:00] [BUILDINGS-Hotel/SocialBusiness] casino_social_business: Harvesting...
[03:26:56] -> Visiting: [casino_social_business] 482 times.

I think wonder radius is cause ...

dada79

Posts : 53
Points : 38
Join date : 2011-09-21

Back to top Go down

Re: Project DEVIL 1.10 (29.10.2011)

Post  <BQ> on Sat Sep 24, 2011 1:36 am

dada79 wrote:
Code:
[03:27:01] ERROR: Wonder::getRadius - Invalid client enqueue time
[03:27:00] -> Harvesting: casino_social_business (id:5363)
[03:27:00] [BUILDINGS-Hotel/SocialBusiness] casino_social_business: Harvesting...
[03:26:56] -> Visiting: [casino_social_business] 482 times.

I think wonder radius is cause ...

without wonder it's working
but, it gives only bonus, when the wonder is activated



Last edited by <BQ> on Sat Sep 24, 2011 4:05 am; edited 1 time in total

<BQ>

Posts : 221
Points : 226
Join date : 2011-09-21

Back to top Go down

Re: Project DEVIL 1.10 (29.10.2011)

Post  dada79 on Sat Sep 24, 2011 2:49 am

<BQ> wrote:
dada79 wrote:
Code:
[03:27:01] ERROR: Wonder::getRadius - Invalid client enqueue time
[03:27:00] -> Harvesting: casino_social_business (id:5363)
[03:27:00] [BUILDINGS-Hotel/SocialBusiness] casino_social_business: Harvesting...
[03:26:56] -> Visiting: [casino_social_business] 482 times.

I think wonder radius is cause ...

without wonder it's working
but, it gives only bonus, when the wonder is activated

the new funktion
'clientEnqueueTime'
is due

i tried with
Code:
$this->GetTimers($stamp, $enqueueTime);
$amf->_bodys[0]->_value[1][0]['params'][3]['clientEnqueueTime'] = intval($enqueueTime);

but doesn't work anymore ...

dada79

Posts : 53
Points : 38
Join date : 2011-09-21

Back to top Go down

Re: Project DEVIL 1.10 (29.10.2011)

Post  <BQ> on Sat Sep 24, 2011 3:12 am

is the new function maybe too on the buisniss buildings?

Code:

Loading configuration...
Harvesting (bus_frenchrest_2) x=14 y=28
ERROR: Internal Server Error
Collecting business buildings starting

after puting the wonder to inventory all works fine

Code:

lBONUSl streakBonus3: 10312 coins
Collecting business buildings starting
Coins: xxx Goods: xxx Energy: 47
Loading configuration...
Ÿ(success): Visiting: [bus_frenchrest_2] 50 times.
Ÿ(success): Visiting: [bus_frenchrest_2] 100 times.
Making business buildings ready (before supply)
Coins: xxx Goods: xxx Energy: 47
Loading configuration...
Supply (bus_frenchrest_2) x=14 y=28
Supply business buildings starting
Coins: xxx Goods: xxx Energy: 47
Loading configuration...
Harvesting (bus_frenchrest_2) x=14 y=28
lBONUSl streakBonus3: 10312 coins
Collecting business buildings starting

funny ...
after recheck with charles, the function 'clientEnqueueTime' is not away


and the bot works for the Hotels


Last edited by <BQ> on Sat Sep 24, 2011 4:09 am; edited 1 time in total

<BQ>

Posts : 221
Points : 226
Join date : 2011-09-21

Back to top Go down

Re: Project DEVIL 1.10 (29.10.2011)

Post  jrwinl on Sat Sep 24, 2011 3:44 am

jrwinl wrote:Hey guys, has anybody encountered this error?



I'm running Windows 7, updated flash, run the bot as admin.
When I open the bot, this error comes out after a minute or so and nothing else happens after that.
I tried to close it and run again but the same thing happens.

I tried to run the bot on a Windows XP virtual machine. At first all seems to go well. The game loads properly and I don't get the error above but all I see is the "Bot Working" image in the "Home" tab and the log says

BOT IS RUNNING.
AMF Data Saved.
Headers Saved.
AMF DATA FOUND.
WAITING AMF DATA.

I waited for more than 30 minutes and nothing happens. Help pls.
thanks.

jrwinl

Posts : 2
Points : 3
Join date : 2011-09-23

Back to top Go down

Re: Project DEVIL 1.10 (29.10.2011)

Post  Admin on Sat Sep 24, 2011 10:54 am

dada79 wrote:
Code:
BOT IS STOPED.
If running on windows 7, please run the bot as administrator
Cannot find MainRequest.bin or Headers.bin
è Bot Init [Phase 1]

--------------------------------------------------------------------------------
BOT IS RUNNING.
BOT IS STOPED.
If running on windows 7, please run the bot as administrator
Cannot find MainRequest.bin or Headers.bin
è Bot Init [Phase 1]

--------------------------------------------------------------------------------
BOT IS RUNNING.
BOT IS STOPED.
ERROR: User not foundThe session expired, the bot will restart in 5 seconds
WAITING AMF DATA.
ERROR: User not foundThe session expired, the bot will restart in 5 seconds
Loading configuration...
UpdateXML
è Bot Init [Phase 1]
It may happens when you install the BOT files inside a directory that wasnt made by you.. Ex: C:\Program files (created by the system)..
running the bot as Administrator will aboid this error

Admin
Admin

Posts : 80
Points : 50
Join date : 2011-09-21

http://cityvillebot.forumotion.eu

Back to top Go down

Re: Project DEVIL 1.10 (29.10.2011)

Post  Admin on Sat Sep 24, 2011 11:01 am

<BQ> wrote:
after recheck with charles, the function 'clientEnqueueTime' is not away


you can see a little diference between enqueueTime and clientEnqueueTime...
enqueueTime: finish with ,162
clientEnqueueTime: looks like its just the integer part.. you can use the function floor(floatval(clientEnqueueTime)) and see if it works
intval sometimes may not work as expected.. you can see that the Type on image still "Number".. intval will turn into Integer.. maybe theres some conflict on that

Admin
Admin

Posts : 80
Points : 50
Join date : 2011-09-21

http://cityvillebot.forumotion.eu

Back to top Go down

Re: Project DEVIL 1.10 (29.10.2011)

Post  dada79 on Sat Sep 24, 2011 12:26 pm

Admin wrote:
dada79 wrote:
Code:
BOT IS STOPED.
If running on windows 7, please run the bot as administrator
Cannot find MainRequest.bin or Headers.bin
è Bot Init [Phase 1]

--------------------------------------------------------------------------------
BOT IS RUNNING.
BOT IS STOPED.
If running on windows 7, please run the bot as administrator
Cannot find MainRequest.bin or Headers.bin
è Bot Init [Phase 1]

--------------------------------------------------------------------------------
BOT IS RUNNING.
BOT IS STOPED.
ERROR: User not foundThe session expired, the bot will restart in 5 seconds
WAITING AMF DATA.
ERROR: User not foundThe session expired, the bot will restart in 5 seconds
Loading configuration...
UpdateXML
è Bot Init [Phase 1]
It may happens when you install the BOT files inside a directory that wasnt made by you.. Ex: C:\Program files (created by the system)..
running the bot as Administrator will aboid this error
I am running bot as admin ,and my bot directory is C:\Users\XXX\Desktop\ , so what can i do to fix it ??? move bot directory to C:\ ???

dada79

Posts : 53
Points : 38
Join date : 2011-09-21

Back to top Go down

Re: Project DEVIL 1.10 (29.10.2011)

Post  Admin on Sat Sep 24, 2011 12:34 pm

dada79 wrote:
I am running bot as admin ,and my bot directory is C:\Users\XXX\Desktop\ , so what can i do to fix it ??? move bot directory to C:\ ???

C:\Users still a System directory..
i run my bot on C:\CityVilleBot very well without needed of Admin rights

Admin
Admin

Posts : 80
Points : 50
Join date : 2011-09-21

http://cityvillebot.forumotion.eu

Back to top Go down

Re: Project DEVIL 1.10 (29.10.2011)

Post  Sponsored content


Sponsored content


Back to top Go down

Page 3 of 12 Previous  1, 2, 3, 4 ... 10, 11, 12  Next

View previous topic View next topic Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum